Visual studio WPF controls works neither in 2015 nor 2017
Print Topic | Close Window

By Harald Boeglmueller - 7 Years Ago
Nevron Open Vision 2017 V01
Visual Studio 2015 Professional and Visual Studio 2017 Professional

I use the Nevron Open Vision C# WPF Template "NOV WPF application".
Everytime i would like to add a WPF Control, like the NButton, to the Designer, the same Windows with following message appears
The following reference has been added to the project
In order to use types from the new reference, press OK to restart
the XAML Designer. After the XAML Designer restarts, re-create
the control on the artboard.

Strange thing is, the reference are already added.
After pressing OK, nothing happens. A redraw on the designer changes nothing.
No Button appears.

After pressing OK, i can draw a new button and new code appears inside XAML.
But, the Button is always a gray rectangle, nothing more.
No Button Image and no smart tag for the control properties.
Same if i use other controls.

I reinstalled Nevron Open Vision and as well VS2015 and VS2017. Nothing changes.
Also i tried two different machines.
If i use standard MS controls, all works fine.

There still other funny behaviour, but lets start with this.
By Nevron Support - 7 Years Ago
  • Microsoft.Windows.Design.Extensibility.dll
  • Microsoft.Windows.Design.Interaction.dll
We tried to install them in the GAC using the gacutil command line tool that comes with Visual Studio 2015, but that failed, too. The tool reported that it successfully installed the assemblies, but it actually didn‘t.

We will investigate this issue further and let you know when we have more information. Until then, you can create, configure and use NOV widgets directly via code. The benefit of not using the designer and creating your NOV UI via code is that your code will be portable, which means that you will be able to use the same code to target other platforms, too, for example - macOS.