Populate "Insert Merge Fields" drop down on mail merge tool bar with data source added from code

Print Topic | Close Window

By Mike Willis - 3 Years Ago
When setting the mail merge data source using the code below i am unable to see the field names in the "Insert merge field" drop down on the mail merge tool bar.
What am i missing to be able to set merge fields?
NDBMailMergeDataSource nDBMailMergeDataSource = new NDBMailMergeDataSource(Nevron.Nov.Data.ENDbConnectionType.SqlServer, "Data Source=w10Mike;Initial Catalog=Pats;Integrated Security=True", "SELECT Id, field1, field2 FROM tableone");

    this.RichTextView.Content.MailMerge.DataSource = nDBMailMergeDataSource;
By Nevron Support - 3 Years Ago
Hi Mike,
What is the version you're currently using? We just tested this with and it was working properly...
By Mike Willis - 3 Years Ago
Thanks for the reply.
I am using version
Also i have found that it appears to work correctly outside of VS 2017 Community debugger.
When i run it in the debugger the output window is filled with 
Exception thrown: 'System.ArgumentException' in Nevron.Nov.Presentation.dll' errors and the program locks up.
 I have attached my test project and the output window text when i run the program.
I need to be able to run the program in the debugger for testing!
Any assistance would be appreciated.

By Nevron Support - 3 Years Ago
Hi Mike,
We tested with Community edition and it was working, however you probably need to enable Just My Code debugger option in order not to break on exceptions in Presentation.dll. These exceptions btw are normal and are caused by the font interpretter when it rebuilds the font previews - certain fonts contain bad hinting code and fail to hint correctly. There was an issue in the field preview (DB connection cloning was not correct) which is fixed and will appear in the next version. Let us know how it goes when you turn on Just My Code from the debugger options...
By Mike Willis - 3 Years Ago
Thanks, setting just my code got me past the issue.
Thanks for the extra effort!