A little confused on version's .Net compatibility


https://www.nevron.com/Forum/Topic8647.aspx
Print Topic | Close Window

By Jason Irby - 6 Years Ago
We are currently using Nevron Diagram version 10.6.23.12 with VS 2005. (Don't laugh.)

We are upgrading to VS 2013 and would like to upgrade to:
Nevron Vision for .NET 2014.1 for VS2013 .NET 4.5 (build version: 14.6.27.12)

However we are concerned about the .Net 4.5.  Does that mean it supports "up-to" 4.5 or that it "requires" 4.5?
We still need to support clients on who are on XP, so we can't require higher than .Net 4.0.

Would software written with Nevron Vision for .NET 2014.1 for VS2013 .NET work with .Net 4.0 or even 2.0?

Thanks in advance,
Jason



By Nevron Support - 6 Years Ago
Hi Jason,

Nevron Vision for .NET 2014.1 is compiled with the default version of Visual Studio it is targeting. The .NET framework versions per edition are:

VS2005 - .NET 2.0
VS2008 - .NET 2.0
VS2010 - .NET 4.0
VS2012 - .NET 4.5
VS2013 - .NET 4.5

In your case you can simply install one of the editions for previous versions of VS (2005, 2008 or 2010) and simply reference the dlls in the Bin folder (for example c:\Program Files (x86)\Nevron Software\Nevron .NET Vision 2014.1 for VS2010\Bin\). There is no problem to develop with VS2013 using the components compiled for a previous version of VS / .NET. The only restriction is that you'll have to manually place them in the VS toolbox. Hope this helps let us know if you meet any problems or have any questions.