Error : The base class 'Nevron.UI.WinForm.Controls.NForm' could not be loaded
Print Topic | Close Window

By Abhay Deshpande - 6 Years Ago

Issue in short :
We cannot open any form in 'Designer' mode which are based on NForm. It shows error as mentioned above.

Issue in detail :
1. We have been using Nevron .NET Vision 2012.1 for VS2012 (Nevron User Interface for .NET - Enterprise Edition) since 2013. We have built several projects based on NForm successfully.

2. We use VS2012 Ultimate on Windows 7 Professional (64bit).

3. Till yesterday evening, all projects were working normally. I mean, we were able to open any NForm in Designer mode.

4. Today morning, I am not able to open any form in Designer mode (I 'hibernate'd computer yesterday evening after closing Visual Studio).

5. Even sample projects given by Nevron are not opening in Designer mode and are showing same error.

6. All project 'references' are fine. The projects compile well and executables run without any issues. I am just not able to open any NForm in Designer mode.

7. I checked toolbox and found that Nevron UI Components are missing. I re-added them (Nevron.Presentation.dll and Nevron.UI.WinForm.Controls.Docking.dll). At this time, I found that NForm is not listed as one of the components after Nevron.Presentation.dll was selected. This was strange. Please see screenshot :

8. I checked Nevron.Presentation.XML. It lists NForm. there. Both files (Nevron.Presentation.dll and Nevron.Presentation.XML) are 'as is' after installation and we have not touched / edited them. Please see screenshot : . You can also see 'date modified' timestamp in explorer.

9. I checked 'License Key Manager' and I could see 2 active keys as below on same development computer:
Version Id [v2012Vol1]
Key Type [Design]
Machine Id [*****] //Its a numeric code - masked here on forum
Product Type [NETUserInterface]
Edition Type [Enterprise]

Version Id [v2012Vol1]
Key Type [Desktop]
Client Id [*****] //Its a numeric code - masked here on forum
Product Type [NETUserInterface]
Edition Type [Enterprise]

I googled on this issue and found similar issues - but could not resolve my issue using the available solutions. I have closed all open documents in VS, rebuilt the solution many no. of times. I have even cold rebooted the laptop. But no avail. I am stumped and without any clue. I have not tried reinstallation of Nevron Product or VS yet.

Any pointers ? Thanks in advance.

Best Regards,
Abhay Deshpande