Profile Picture

Line chart draws wrong when all y axis values are same

Posted By Niranjan Singh 3 Years Ago
Author
Message
Niranjan Singh
Problem Posted 3 Years Ago
View Quick Profile
Forum Member

Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)

Group: Forum Members
Last Active: 3 Weeks Ago
Posts: 47, Visits: 171
Hi Team,

I am drawing line series with DataTime Scale on X-axis. I found an issue that chart draws wrong when data values are same for all series points. See below images for drawn chart and chart values:

https://www.nevron.com/forum/uploads/images/04cc6f16-48b2-4c6a-be8d-2dc4.png 
Actual Data is as below:
https://www.nevron.com/forum/uploads/images/6d98daf1-85a3-42cc-9175-e74f.png

You can find running sample project at - https://github.com/niranjankala/Nevron.git. This sample project uses Nevron version 13.8.26.12. Kindly suggest the settings to solve the issue.

Thanks,
Niranjan

Nevron Support
Posted 3 Years Ago
View Quick Profile
Supreme Being

Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 2,879, Visits: 3,045
Hi Niranjan,

We were not able to replicate this issue with the latest version of the control. In the newer version you also have the option to use spline line segments in the regular line series:
line.PolylineRenderMode = PolylineRenderMode.Curve;
Let us know if you meet any problems.


Best Regards,
Nevron Support Team



Niranjan Singh
Posted 3 Years Ago
View Quick Profile
Forum Member

Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)Forum Member (40 reputation)

Group: Forum Members
Last Active: 3 Weeks Ago
Posts: 47, Visits: 171
Thanks for the reply.
It is good that it works fine with the newer version of Nevron Vision, but is there any workaround to make it work in the older version? 



Nevron Support
Posted 3 Years Ago
View Quick Profile
Supreme Being

Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)Supreme Being (3,905 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 2,879, Visits: 3,045
Hi Niranjan,
We're not aware of any workarounds for the smooth line in this version. Please consider upgrading to the latest version of the control, which is actively supported / maintained.

Best Regards,
Nevron Support Team





Similar Topics


Reading This Topic