Profile Picture

An exception occurred while processing request

Posted By Mike O'Ceirin Last Year
Author
Message
Mike O'Ceirin
Problem Posted Last Year
View Quick Profile
Forum Newbie

Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 21, Visits: 182
I get this from any chart if there is inactivity. It occurs when I try to scroll through the chart data. I am connected to a SQL Server database remotely and the chart is using about 9000 data points. It appears to be a timeout. Is it deliberate from the chart control or the data connection? Either way is there a solution? Can I send a keep alive pulse?



Nevron Support
Posted Last Year
View Quick Profile
Supreme Being

Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)

Group: Forum Members
Last Active: 48 minutes ago
Posts: 2,945, Visits: 3,306
Hi Mike,

The chart state is saved in the session state on the server - when it expires due to a long period of inactivity the control will display this message. You can consider to increase the session state timeout in the web.config of the app:

<configuration>
<system.web>
<sessionState timeout="20">
</sessionState>
</system.web>
</configuration>.

or enable auto update which does nothing (check out ThinWeb \ Auto Update example) say every 10 minutes or so. That way the session state will be kept alive and you'll not hit the timeout.

We hope this helps - let us know if you meet any problems or have any questions.


Best Regards,
Nevron Support Team



Mike O'Ceirin
Posted Last Year
View Quick Profile
Forum Newbie

Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 21, Visits: 182
Thank you supreme being. I will try the simpler option first and give it about an hour. The auto update will probably use at a later date. Is it possible to catch the exception and to give a more friendly message?

Nevron Support
Posted Last Year
View Quick Profile
Supreme Being

Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)

Group: Forum Members
Last Active: 48 minutes ago
Posts: 2,945, Visits: 3,306
Hi Mike,

Currently, there is no way to change the exception formatting, however, users are not supposed to see that message anyway. Let us know if you experience any problems after you increase the session timeout.

(BTW the “Supreme Being” rank is assigned by the forum manufacturer based on the number of posts – this is a third party not related to Nevron. We may try change that though it sounds good 😊)


Best Regards,
Nevron Support Team



Mike O'Ceirin
Posted Last Year
View Quick Profile
Forum Newbie

Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: Forum Members
Last Active: Last Week
Posts: 21, Visits: 182
If I go for the auto update that would have to be implemented for very chart on my my website would it not?

I thought you must be the supreme being since you certainly seem to be omniscient.


Nevron Support
Posted Last Year
View Quick Profile
Supreme Being

Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)Supreme Being (4,063 reputation)

Group: Forum Members
Last Active: 48 minutes ago
Posts: 2,945, Visits: 3,306
Hi MIke,

The auto-update will have to be implemented on each page containing a chart. The session state fix will be global for the application. Let us know if you meet any problems with the implementation.


Best Regards,
Nevron Support Team





Similar Topics


Reading This Topic