Profile Picture

License popup when no internet connection.

Posted By kjlk jlkjkl 9 Years Ago
Author
Message
kjlk jlkjkl
Posted 9 Years Ago
View Quick Profile
Forum Newbie

Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: Forum Members
Last Active: 9 Years Ago
Posts: 2, Visits: 1

We have implemented Nevron Chart.net components (version 9.5.11.12) in our application. When we run the application on a computer that has an internet connection there are no problems.

If we run the application on a computer that has no internet connection, we got a popup that mentions that the validation has failed. Clicking on the purchase button makes the popup disapear as long as the application is running. After a restart of the application the popup is back again.

It seems that the Nevron components are checking through the internet if there license is valid and that they do this everytime.

Is there a way of avoiding this check, or suppress the popup as we need to be able to run our application on networks that have no internet connection?

Marco de Brouwer



Nevron Support
Posted 9 Years Ago
View Quick Profile
Supreme Being

Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)Supreme Being (3,959 reputation)

Group: Forum Members
Last Active: 40 minutes ago
Posts: 2,893, Visits: 3,107

Hi Marco,

The controls do not establish an internet connection to verify the license key. Most likely this is a UI licensing issue - please check where the application uses the UI and if it is licensed for that.



Best Regards,
Nevron Support Team



kjlk jlkjkl
Posted 9 Years Ago
View Quick Profile
Forum Newbie

Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: Forum Members
Last Active: 9 Years Ago
Posts: 2, Visits: 1

How does this explain the behaviour that I see with a test I ran with a laptop.

1) Hooked up the laptop to a network with internet connection and I did not get the popup.

2) Hooked up the same laptop to a standalone network and I did get the popup.

3) Hooked the laptop again to the one with the internet connection and the popup was gone again.

As I did not made any modifications to the laptop between switching networks it seems to me that licenses are set correct.

Otherwise I think I should have seen the message on both occassions. And the only difference I see is the connection to the internet.

I hope that you can help me further on this one.

Marco

 

 





Similar Topics


Reading This Topic