Profile Picture

Populate "Insert Merge Fields" drop down on mail merge tool bar with data source added from code

Posted By Mike Willis Last Year

Populate "Insert Merge Fields" drop down on mail merge tool bar with...

Author
Message
Mike Willis
Question Posted Last Year
View Quick Profile
Forum Newbie

Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 18, Visits: 106
When setting the mail merge data source using the code below i am unable to see the field names in the "Insert merge field" drop down on the mail merge tool bar.
What am i missing to be able to set merge fields?
NDBMailMergeDataSource nDBMailMergeDataSource = new NDBMailMergeDataSource(Nevron.Nov.Data.ENDbConnectionType.SqlServer, "Data Source=w10Mike;Initial Catalog=Pats;Integrated Security=True", "SELECT Id, field1, field2 FROM tableone");

    
    this.RichTextView.Content.MailMerge.DataSource = nDBMailMergeDataSource;

Nevron Support
Posted Last Year
View Quick Profile
Supreme Being

Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)

Group: Forum Members
Last Active: 2 Weeks Ago
Posts: 2,878, Visits: 3,040
Hi Mike,
What is the version you're currently using? We just tested this with 18.12.18.12 and it was working properly...

Best Regards,
Nevron Support Team



Mike Willis
Posted Last Year
View Quick Profile
Forum Newbie

Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 18, Visits: 106
Thanks for the reply.
I am using version 18.12.18.12.
Also i have found that it appears to work correctly outside of VS 2017 Community debugger.
When i run it in the debugger the output window is filled with 
Exception thrown: 'System.ArgumentException' in Nevron.Nov.Presentation.dll' errors and the program locks up.
 I have attached my test project and the output window text when i run the program.
I need to be able to run the program in the debugger for testing!
Any assistance would be appreciated.
Mike




Attachments
nevronerror.txt (117 views, 33.00 KB)
NevronError.zip (111 views, 523.00 KB)
Nevron Support
Posted Last Year
View Quick Profile
Supreme Being

Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)Supreme Being (3,904 reputation)

Group: Forum Members
Last Active: 2 Weeks Ago
Posts: 2,878, Visits: 3,040
Hi Mike,
We tested with Community edition and it was working, however you probably need to enable Just My Code debugger option in order not to break on exceptions in Presentation.dll. These exceptions btw are normal and are caused by the font interpretter when it rebuilds the font previews - certain fonts contain bad hinting code and fail to hint correctly. There was an issue in the field preview (DB connection cloning was not correct) which is fixed and will appear in the next version. Let us know how it goes when you turn on Just My Code from the debugger options...

Best Regards,
Nevron Support Team



Mike Willis
Posted Last Year
View Quick Profile
Forum Newbie

Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)Forum Newbie (0 reputation)

Group: Forum Members
Last Active: Last Month
Posts: 18, Visits: 106
Thanks, setting just my code got me past the issue.
Thanks for the extra effort!





Similar Topics


Reading This Topic